summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-12-21 03:28:48 +0000
committerZac Medico <zmedico@gentoo.org>2007-12-21 03:28:48 +0000
commitcd059b0c37fb7b1d48530a4a8babb09867aced24 (patch)
tree87b7775645453d309665a51bddc8d903ebcf6bb6 /bin/repoman
parent9577efdcd75bf8416348a5e8b5d13ae6a5343231 (diff)
downloadportage-cd059b0c37fb7b1d48530a4a8babb09867aced24.tar.gz
portage-cd059b0c37fb7b1d48530a4a8babb09867aced24.tar.bz2
portage-cd059b0c37fb7b1d48530a4a8babb09867aced24.zip
Eliminate redundant "notadded" error filtering.
svn path=/main/trunk/; revision=9023
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman8
1 files changed, 1 insertions, 7 deletions
diff --git a/bin/repoman b/bin/repoman
index 68a692d57..e7b841282 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -477,9 +477,6 @@ def last(full=False):
for x in qacats:
if not stats[x]:
continue
- if "notadded" in x and not isCvs:
- stats[x] = 0
- continue
dowarn = 1
if x not in qawarnings:
dofail = 1
@@ -1214,7 +1211,7 @@ for x in scanlist:
if os.stat(checkdir+"/"+y+".ebuild")[0] & 0x0248:
stats["file.executable"] += 1
fails["file.executable"].append(x+"/"+y+".ebuild")
- if y not in eadded:
+ if isCvs and y not in eadded:
#ebuild not added to cvs
stats["ebuild.notadded"]=stats["ebuild.notadded"]+1
fails["ebuild.notadded"].append(x+"/"+y+".ebuild")
@@ -1645,9 +1642,6 @@ dofull = options.mode not in ("full", "lfull")
for x in qacats:
if not stats[x]:
continue
- if "notadded" in x and not isCvs:
- stats[x] = 0
- continue
dowarn = 1
if x not in qawarnings:
dofail = 1