summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-22 12:42:42 -0500
committerMike Frysinger <vapier@gentoo.org>2012-11-22 12:42:42 -0500
commite9dc56625152991ba535f5be3ab88fc7ec8dbcfc (patch)
tree0e2beb346f0f25475a0e95cfe8cbcb5dc89695d9 /bin/repoman
parentda268c268e7fb91318a4676025ec841a4444b362 (diff)
downloadportage-e9dc56625152991ba535f5be3ab88fc7ec8dbcfc.tar.gz
portage-e9dc56625152991ba535f5be3ab88fc7ec8dbcfc.tar.bz2
portage-e9dc56625152991ba535f5be3ab88fc7ec8dbcfc.zip
strip trailing whitespace
No functional changes here. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman28
1 files changed, 14 insertions, 14 deletions
diff --git a/bin/repoman b/bin/repoman
index 91a98153b..7ecdc6d19 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -125,7 +125,7 @@ signal.signal(signal.SIGINT,exithandler)
class RepomanHelpFormatter(optparse.IndentedHelpFormatter):
"""Repoman needs it's own HelpFormatter for now, because the default ones
murder the help text."""
-
+
def __init__(self, indent_increment=1, max_help_position=24, width=150, short_first=1):
optparse.HelpFormatter.__init__(self, indent_increment, max_help_position, width, short_first)
@@ -135,7 +135,7 @@ class RepomanHelpFormatter(optparse.IndentedHelpFormatter):
class RepomanOptionParser(optparse.OptionParser):
"""Add the on_tail function, ruby has it, optionParser should too
"""
-
+
def __init__(self, *args, **kwargs):
optparse.OptionParser.__init__(self, *args, **kwargs)
self.tail = ""
@@ -169,7 +169,7 @@ def ParseArgs(argv, qahelp):
'help' : 'Show this screen',
'manifest' : 'Generate a Manifest (fetches files if necessary)',
'manifest-check' : 'Check Manifests for missing or incorrect digests',
- 'scan' : 'Scan directory tree for QA issues'
+ 'scan' : 'Scan directory tree for QA issues'
}
mode_keys = list(modes)
@@ -196,7 +196,7 @@ def ParseArgs(argv, qahelp):
parser.add_option('-p', '--pretend', dest='pretend', default=False,
action='store_true', help='don\'t commit or fix anything; just show what would be done')
-
+
parser.add_option('-q', '--quiet', dest="quiet", action="count", default=0,
help='do not print unnecessary messages')
@@ -244,7 +244,7 @@ def ParseArgs(argv, qahelp):
parser.add_option('--without-mask', dest='without_mask', action='store_true',
default=False, help='behave as if no package.mask entries exist (not allowed with commit mode)')
- parser.add_option('--mode', type='choice', dest='mode', choices=list(modes),
+ parser.add_option('--mode', type='choice', dest='mode', choices=list(modes),
help='specify which mode repoman will run in (default=full)')
parser.on_tail("\n " + green("Modes".ljust(20) + " Description\n"))
@@ -279,7 +279,7 @@ def ParseArgs(argv, qahelp):
if not opts.mode:
opts.mode = 'full'
-
+
if opts.mode == 'ci':
opts.mode = 'commit' # backwards compat shortcut
@@ -329,7 +329,7 @@ qahelp={
"KEYWORDS.dropped":"Ebuilds that appear to have dropped KEYWORDS for some arch",
"KEYWORDS.missing":"Ebuilds that have a missing or empty KEYWORDS variable",
"KEYWORDS.stable":"Ebuilds that have been added directly with stable KEYWORDS",
- "KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask",
+ "KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask",
"LICENSE.missing":"Ebuilds that have a missing or empty LICENSE variable",
"LICENSE.virtual":"Virtuals that have a non-empty LICENSE variable",
"DESCRIPTION.missing":"Ebuilds that have a missing or empty DESCRIPTION variable",
@@ -1632,7 +1632,7 @@ for x in effective_scanlist:
if check_changelog and "ChangeLog" not in checkdirlist:
stats["changelog.missing"]+=1
fails["changelog.missing"].append(x+"/ChangeLog")
-
+
musedict = {}
#metadata.xml file check
if "metadata.xml" not in checkdirlist:
@@ -1995,7 +1995,7 @@ for x in effective_scanlist:
badlicsyntax = len([z for z in type_list if z == "LICENSE"])
badprovsyntax = len([z for z in type_list if z == "PROVIDE"])
- baddepsyntax = len(type_list) != badlicsyntax + badprovsyntax
+ baddepsyntax = len(type_list) != badlicsyntax + badprovsyntax
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
@@ -2025,7 +2025,7 @@ for x in effective_scanlist:
for mypos in range(len(myuse)):
stats["IUSE.invalid"]=stats["IUSE.invalid"]+1
- fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])
+ fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])
# license checks
if not badlicsyntax:
@@ -2127,7 +2127,7 @@ for x in effective_scanlist:
# A missing profile will create an error further down
# during the KEYWORDS verification.
continue
-
+
for prof in profiles[arch]:
if prof.status not in ("stable", "dev") or \
@@ -2192,7 +2192,7 @@ for x in effective_scanlist:
suffix=suffix+"indev"
for mytype in Package._dep_keys:
-
+
mykey = "dependency.bad" + suffix
myvalue = myaux[mytype]
if not myvalue:
@@ -2403,7 +2403,7 @@ else:
with repoman_popen("hg status --no-status --unknown .") as f:
myunadded = f.readlines()
myunadded = ["./" + elem.rstrip() for elem in myunadded]
-
+
# Mercurial doesn't handle manually deleted files as removed from
# the repository, so the user need to remove them before commit,
# using "hg remove [FILES]"
@@ -2707,7 +2707,7 @@ else:
elif vcs == "svn":
if myfile not in expansion:
continue
-
+
# Subversion keywords are case-insensitive in svn:keywords properties, but case-sensitive in contents of files.
enabled_keywords = []
for k in expansion[myfile]: