summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-03-28 04:14:50 +0000
committerZac Medico <zmedico@gentoo.org>2008-03-28 04:14:50 +0000
commit52c5df5982624e32638af732a600516ce82ac979 (patch)
treebdcb0ac67d39fddf0fe9edc771b30b8221eada4f /bin
parent68b10f5dcd17618959726143dc890f2618123f7a (diff)
downloadportage-52c5df5982624e32638af732a600516ce82ac979.tar.gz
portage-52c5df5982624e32638af732a600516ce82ac979.tar.bz2
portage-52c5df5982624e32638af732a600516ce82ac979.zip
Bug #213629 - Use EAPI.incompatible in cases where EAPI=0 and a default
IUSE is encountered. svn path=/main/trunk/; revision=9525
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman11
1 files changed, 9 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index f89e1de74..08c3f1926 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1192,8 +1192,15 @@ for x in scanlist:
for mypos in range(len(myuse)-1,-1,-1):
if myuse[mypos] and (myuse[mypos] in luselist[mykey]):
del myuse[mypos]
- if default_use and myaux["EAPI"] == "0":
- myuse += default_use
+
+ if default_use and eapi == "0":
+ for myflag in default_use:
+ stats['EAPI.incompatible'] += 1
+ fails['EAPI.incompatible'].append(
+ (relative_path + ": IUSE defaults" + \
+ " not supported with EAPI='%s':" + \
+ " '%s'") % (eapi, myflag))
+
for mypos in range(len(myuse)):
stats["IUSE.invalid"]=stats["IUSE.invalid"]+1
fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])