summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-03-27 22:03:54 +0000
committerZac Medico <zmedico@gentoo.org>2008-03-27 22:03:54 +0000
commit5b03aa476c7b6761084700e5837ef513e35c4db5 (patch)
tree9867faedfdbfbcb745969135b39f273937d25a3a /bin
parent91cae42bc7f7038acd5d301a51e5b4b6710e21c1 (diff)
downloadportage-5b03aa476c7b6761084700e5837ef513e35c4db5.tar.gz
portage-5b03aa476c7b6761084700e5837ef513e35c4db5.tar.bz2
portage-5b03aa476c7b6761084700e5837ef513e35c4db5.zip
Bug #212509 - Display a note about the --without-mask option when there
are masked packages. svn path=/main/trunk/; revision=9521
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman8
1 files changed, 7 insertions, 1 deletions
diff --git a/bin/repoman b/bin/repoman
index c4fa7ba32..4ed1a34b7 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -185,7 +185,7 @@ def ParseArgs(args, qahelp):
parser.add_option('-i', '--ignore-arches', dest='ignore_arches', action='store_true',
default=False, help='ignore arch-specific failures (where arch != host)')
- parser.add_option('-I', '--ignored-masked', dest='ignore_masked', action='store_true',
+ parser.add_option('-I', '--ignore-masked', dest='ignore_masked', action='store_true',
default=False, help='ignore masked packages (not allowed with commit mode)')
parser.add_option('--without-mask', dest='without_mask', action='store_true',
@@ -696,6 +696,7 @@ if isCvs:
new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
del mycvstree, mynew
+have_masked = False
dofail = 0
arch_caches={}
arch_xmatch_caches = {}
@@ -1284,6 +1285,7 @@ for x in scanlist:
ismasked = os.path.join(catdir, y) not in \
portdb.xmatch("list-visible", x)
if ismasked:
+ have_masked = True
if options.ignore_masked:
continue
#we are testing deps for a masked package; give it some lee-way
@@ -1409,6 +1411,10 @@ def grouplist(mylist,seperator="/"):
mygroups[xs[0]]+=[seperator.join(xs[1:])]
return mygroups
+if have_masked and not (options.without_mask or options.ignore_masked):
+ print bold("Note: use --without-mask to check " + \
+ "KEYWORDS on dependencies of masked packages")
+
if options.mode != 'commit':
if dofull:
print bold("Note: type \"repoman full\" for a complete listing.")