summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-01 17:15:39 +0300
committerZac Medico <zmedico@gentoo.org>2013-01-01 16:28:05 -0800
commit63bf20d0925ca76c98477a108a6d4c3fa8fde885 (patch)
tree42fc2c97ecad3b1ca5d5a6754731c1d524c52f3f /bin
parent0c38140e331c040530bf1d6c5716696162790bda (diff)
downloadportage-63bf20d0925ca76c98477a108a6d4c3fa8fde885.tar.gz
portage-63bf20d0925ca76c98477a108a6d4c3fa8fde885.tar.bz2
portage-63bf20d0925ca76c98477a108a6d4c3fa8fde885.zip
repoman: tell user which mirror identifiers contain SRC_URI
before the patch: $ repoman full RepoMan scours the neighborhood... metadata.missing 1 dev-haskell/qthaskellc/metadata.xml SRC_URI.mirror 1 dev-haskell/qthaskellc/qthaskellc-1.1.4.ebuild: 'http://download.berlios.de/' found in thirdpartymirrors after the patch: $ repoman full RepoMan scours the neighborhood... metadata.missing 1 dev-haskell/qthaskellc/metadata.xml SRC_URI.mirror 1 dev-haskell/qthaskellc/qthaskellc-1.1.4.ebuild: 'http://download.berlios.de/' found in thirdpartymirrors: 'mirror://berlios' Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman12
1 files changed, 6 insertions, 6 deletions
diff --git a/bin/repoman b/bin/repoman
index 45a7ca57f..92ae667e6 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1267,12 +1267,12 @@ check_ebuild_notadded = not \
(vcs == "svn" and repolevel < 3 and options.mode != "commit")
# Build a regex from thirdpartymirrors for the SRC_URI.mirror check.
-thirdpartymirrors = []
-for v in repoman_settings.thirdpartymirrors().values():
+thirdpartymirrors = {}
+for k, v in repoman_settings.thirdpartymirrors().items():
for v in v:
if not v.endswith("/"):
v += "/"
- thirdpartymirrors.append(v)
+ thirdpartymirrors[v] = k
class _MetadataTreeBuilder(xml.etree.ElementTree.TreeBuilder):
"""
@@ -1772,7 +1772,7 @@ for x in effective_scanlist:
for uri in portage.dep.use_reduce( \
myaux["SRC_URI"], matchall=True, is_src_uri=True, eapi=eapi, flat=True):
contains_mirror = False
- for mirror in thirdpartymirrors:
+ for mirror, mirror_alias in thirdpartymirrors.items():
if uri.startswith(mirror):
contains_mirror = True
break
@@ -1781,8 +1781,8 @@ for x in effective_scanlist:
stats["SRC_URI.mirror"] += 1
fails["SRC_URI.mirror"].append(
- "%s: '%s' found in thirdpartymirrors" % \
- (relative_path, mirror))
+ "%s: '%s' found in thirdpartymirrors: 'mirror://%s'" % \
+ (relative_path, mirror, mirror_alias))
if myaux.get("PROVIDE"):
stats["virtual.oldstyle"]+=1