summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-10-04 15:17:57 -0700
committerZac Medico <zmedico@gentoo.org>2012-10-04 15:17:57 -0700
commit8e5dcfaf9c57da3be20ae673f65c3b5b8d9827c2 (patch)
tree7b55e4b7897ddc8f4968436302c632c847380096 /bin
parent916df01c378dc4a04961effdc209dab791d3e53f (diff)
downloadportage-8e5dcfaf9c57da3be20ae673f65c3b5b8d9827c2.tar.gz
portage-8e5dcfaf9c57da3be20ae673f65c3b5b8d9827c2.tar.bz2
portage-8e5dcfaf9c57da3be20ae673f65c3b5b8d9827c2.zip
ebuild.sh: comment on noauto behavior
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebuild.sh6
1 files changed, 4 insertions, 2 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index a74a84851..de54e22eb 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -520,10 +520,12 @@ if ___eapi_enables_globstar; then
shopt -s globstar
fi
+# Source the ebuild every time for FEATURES=noauto, so that ebuild
+# modifications take effect immediately.
if ! has "$EBUILD_PHASE" clean cleanrm ; then
if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
- -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
- has noauto $FEATURES ; then
+ -f $PORTAGE_BUILDDIR/.ebuild_changed || \
+ " ${FEATURES} " == *" noauto "* ]] ; then
# The bashrcs get an opportunity here to set aliases that will be expanded
# during sourcing of ebuilds and eclasses.
__source_all_bashrcs