summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-01-29 18:46:24 +0000
committerZac Medico <zmedico@gentoo.org>2010-01-29 18:46:24 +0000
commitb90061e5860d8769690ddd41e0e2f487860c85ee (patch)
treee5153a63cee61f2540df70d353a32b1c71860b40 /bin
parente9862541e2c154f466f3a3cbdbc8abc6f59661aa (diff)
downloadportage-b90061e5860d8769690ddd41e0e2f487860c85ee.tar.gz
portage-b90061e5860d8769690ddd41e0e2f487860c85ee.tar.bz2
portage-b90061e5860d8769690ddd41e0e2f487860c85ee.zip
Bug #269225 - Warn about virtuals with non-empty HOMEPAGE or LICENSE. Thanks
to Ulrich Müller <ulm@g.o> for this patch. (trunk r15174) svn path=/main/branches/2.1.7/; revision=15240
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman11
1 files changed, 11 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index b62378197..49f04c6e9 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -278,6 +278,7 @@ qahelp={
"KEYWORDS.stable":"Ebuilds that have been added directly with stable KEYWORDS",
"KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask",
"LICENSE.missing":"Ebuilds that have a missing or empty LICENSE variable",
+ "LICENSE.virtual":"Virtuals that have a non-empty LICENSE variable",
"DESCRIPTION.missing":"Ebuilds that have a missing or empty DESCRIPTION variable",
"DESCRIPTION.toolong":"DESCRIPTION is over %d characters" % max_desc_len,
"EAPI.definition":"EAPI is defined after an inherit call (must be defined before)",
@@ -285,6 +286,7 @@ qahelp={
"EAPI.unsupported":"Ebuilds that have an unsupported EAPI version (you must upgrade portage)",
"SLOT.invalid":"Ebuilds that have a missing or invalid SLOT variable value",
"HOMEPAGE.missing":"Ebuilds that have a missing or empty HOMEPAGE variable",
+ "HOMEPAGE.virtual":"Virtuals that have a non-empty HOMEPAGE variable",
"DEPEND.bad":"User-visible ebuilds with bad DEPEND settings (matched against *visible* ebuilds)",
"RDEPEND.bad":"User-visible ebuilds with bad RDEPEND settings (matched against *visible* ebuilds)",
"PDEPEND.bad":"User-visible ebuilds with bad PDEPEND settings (matched against *visible* ebuilds)",
@@ -360,6 +362,8 @@ qawarnings = set((
"DEPEND.badmaskedindev","RDEPEND.badmaskedindev","PDEPEND.badmaskedindev",
"DEPEND.badtilde", "RDEPEND.badtilde", "PDEPEND.badtilde",
"DESCRIPTION.toolong",
+"HOMEPAGE.virtual",
+"LICENSE.virtual",
"KEYWORDS.dropped",
"KEYWORDS.stupid",
"KEYWORDS.missing",
@@ -1381,6 +1385,13 @@ for x in scanlist:
stats[myqakey]=stats[myqakey]+1
fails[myqakey].append(x+"/"+y+".ebuild")
+ if catdir == "virtual":
+ for var in ("HOMEPAGE", "LICENSE"):
+ if myaux.get(var):
+ myqakey = var + ".virtual"
+ stats[myqakey] = stats[myqakey] + 1
+ fails[myqakey].append(relative_path)
+
# 14 is the length of DESCRIPTION=""
if len(myaux['DESCRIPTION']) > max_desc_len:
stats['DESCRIPTION.toolong'] += 1