summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-01-28 22:14:30 +0000
committerZac Medico <zmedico@gentoo.org>2007-01-28 22:14:30 +0000
commitb9779b943e1bf90991f531794f3240fcf8ef4590 (patch)
tree5913e7ca7c447b4fe64fa7dab69ab095933eda2a /bin
parent712d890261c07e566c9c2c78ac2381343f26f9df (diff)
downloadportage-b9779b943e1bf90991f531794f3240fcf8ef4590.tar.gz
portage-b9779b943e1bf90991f531794f3240fcf8ef4590.tar.bz2
portage-b9779b943e1bf90991f531794f3240fcf8ef4590.zip
Can't delete variable that doesn't exist anymore (bug #164280) (trunk r5816:5817 and r5820:5821)
svn path=/main/branches/2.1.2/; revision=5822
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman16
1 files changed, 12 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 08d6ad4c1..a476bd64a 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1042,12 +1042,20 @@ for x in scanlist:
Ebuilds that inherit a "Live" eclasss (darcs,subversion,git,cvs,etc..) should
not be allowed to be marked stable
"""
- if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
- bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
+ if set(["darcs","cvs","subversion","git"]).intersection(
+ myaux["INHERITED"].split()):
+ bad_stable_keywords = []
+ for keyword in myaux["KEYWORDS"].split():
+ if not keyword.startswith("~") and \
+ not keyword.startswith("-"):
+ bad_stable_keywords.append(keyword)
+ del keyword
if bad_stable_keywords:
stats["LIVEVCS.stable"] += 1
- fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)
- del keyword, bad_stable_keywords
+ fails["LIVEVCS.stable"].append(
+ x + "/" + y + ".ebuild with stable keywords:%s " % \
+ bad_stable_keywords)
+ del bad_stable_keywords
if "--ignore-arches" in myoptions:
arches = [[repoman_settings["ARCH"], repoman_settings["ARCH"],