summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-11-21 10:45:22 +0000
committerZac Medico <zmedico@gentoo.org>2007-11-21 10:45:22 +0000
commitdc1ca65141e30ca2f9e60266de1ae7387e767bef (patch)
tree78bb274e2278c54fb4b9ce7b76bdf1adf9199fad /bin
parent1003c5d35f721ca3da8278987707f7e4452af884 (diff)
downloadportage-dc1ca65141e30ca2f9e60266de1ae7387e767bef.tar.gz
portage-dc1ca65141e30ca2f9e60266de1ae7387e767bef.tar.bz2
portage-dc1ca65141e30ca2f9e60266de1ae7387e767bef.zip
In dyn_install(), don't cleanse S from the global environment,
in case the user wants to repeat the phase (like with FEATURES=noauto and the ebuild command). Only cleanse it from environment.bz2. svn path=/main/trunk/; revision=8583
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebuild.sh14
1 files changed, 9 insertions, 5 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index bed192034..40f34a65f 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1021,11 +1021,15 @@ dyn_install() {
# local variables can leak into the saved environment.
unset f
- # To avoid environment bloat, cleanse variables that are
- # are no longer needed after src_install().
- unset S
-
- save_ebuild_env > environment
+ (
+ # To avoid environment.bz2 bloat, cleanse variables that are
+ # are no longer needed after src_install(). Don't cleanse from
+ # the global environment though, in case the user wants to repeat
+ # this phase (like with FEATURES=noauto and the ebuild command).
+ unset S
+
+ save_ebuild_env > environment
+ )
bzip2 -f9 environment
cp "${EBUILD}" "${PF}.ebuild"