summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-11-24 22:11:14 +0000
committerZac Medico <zmedico@gentoo.org>2007-11-24 22:11:14 +0000
commitf59eb56cbd71337021bbd4e53d457c5cf14c1e8c (patch)
treefe33a152e16de87c5eecb32c1b5abc60ecf28ee9 /bin
parent7d5694628eb9d28f5fece8fb152e6931cc84722c (diff)
downloadportage-f59eb56cbd71337021bbd4e53d457c5cf14c1e8c.tar.gz
portage-f59eb56cbd71337021bbd4e53d457c5cf14c1e8c.tar.bz2
portage-f59eb56cbd71337021bbd4e53d457c5cf14c1e8c.zip
Bug #140180 - Never trigger a LICENSE.missing violation for old style
virtuals since they don't directly install anything. svn path=/main/trunk/; revision=8645
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman6
1 files changed, 4 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index e5893347c..c86b4f322 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1143,8 +1143,10 @@ for x in scanlist:
stats["virtual.exists"]+=1
fails["virtual.exists"].append(x+"/"+y+".ebuild: "+prov_cp)
- for pos in range(0,len(missingvars)):
- if not myaux[missingvars[pos]]:
+ for pos, missing_var in enumerate(missingvars):
+ if not myaux.get(missing_var):
+ if missing_var == "LICENSE" and catdir == "virtual":
+ continue
myqakey=missingvars[pos]+".missing"
stats[myqakey]=stats[myqakey]+1
fails[myqakey].append(x+"/"+y+".ebuild")