summaryrefslogtreecommitdiffstats
path: root/pym/_emerge/EbuildPhase.py
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-02-25 03:37:29 +0000
committerZac Medico <zmedico@gentoo.org>2010-02-25 03:37:29 +0000
commit7d11c874703c23d5b44e5133bd768c63cf313701 (patch)
tree56fa44eaa9baa672de041efce22f85e424d0b771 /pym/_emerge/EbuildPhase.py
parent2b139158d9baa034cb620ad7c92db107ab5991c7 (diff)
downloadportage-7d11c874703c23d5b44e5133bd768c63cf313701.tar.gz
portage-7d11c874703c23d5b44e5133bd768c63cf313701.tar.bz2
portage-7d11c874703c23d5b44e5133bd768c63cf313701.zip
Split doebuild and related code to the portage.package.ebuild module.
svn path=/main/trunk/; revision=15448
Diffstat (limited to 'pym/_emerge/EbuildPhase.py')
-rw-r--r--pym/_emerge/EbuildPhase.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/pym/_emerge/EbuildPhase.py b/pym/_emerge/EbuildPhase.py
index 89bdb078f..81b0e1f8d 100644
--- a/pym/_emerge/EbuildPhase.py
+++ b/pym/_emerge/EbuildPhase.py
@@ -5,6 +5,9 @@
from _emerge.MiscFunctionsProcess import MiscFunctionsProcess
from _emerge.EbuildProcess import EbuildProcess
from _emerge.CompositeTask import CompositeTask
+from portage.package.ebuild.doebuild import _check_build_log, \
+ _post_phase_cmds, _post_src_install_chost_fix, \
+ _post_src_install_uid_fix
from portage.util import writemsg, writemsg_stdout
import portage
from portage import os
@@ -18,8 +21,6 @@ class EbuildPhase(CompositeTask):
__slots__ = ("background", "pkg", "phase",
"scheduler", "settings", "tree")
- _post_phase_cmds = portage._post_phase_cmds
-
def _start(self):
ebuild_process = EbuildProcess(background=self.background,
@@ -39,7 +40,7 @@ class EbuildPhase(CompositeTask):
encoding=_encodings['fs'], errors='strict'),
mode='a', encoding=_encodings['content'], errors='replace')
try:
- portage._check_build_log(self.settings, out=out)
+ _check_build_log(self.settings, out=out)
msg = _unicode_decode(out.getvalue(),
encoding=_encodings['content'], errors='replace')
if msg:
@@ -66,12 +67,12 @@ class EbuildPhase(CompositeTask):
encoding=_encodings['fs'], errors='strict'),
mode='a', encoding=_encodings['content'], errors='replace')
out = log_file
- portage._post_src_install_chost_fix(settings)
- portage._post_src_install_uid_fix(settings, out=out)
+ _post_src_install_chost_fix(settings)
+ _post_src_install_uid_fix(settings, out=out)
if log_file is not None:
log_file.close()
- post_phase_cmds = self._post_phase_cmds.get(self.phase)
+ post_phase_cmds = _post_phase_cmds.get(self.phase)
if post_phase_cmds is not None:
post_phase = MiscFunctionsProcess(background=self.background,
commands=post_phase_cmds, phase=self.phase, pkg=self.pkg,