summaryrefslogtreecommitdiffstats
path: root/pym/portage/tests/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-10-20 13:09:11 -0700
committerZac Medico <zmedico@gentoo.org>2011-10-20 13:09:11 -0700
commit68414e9ffe4c05a0a0e81734b80db61e2782937c (patch)
tree2c8d0e2c953f3244de5d9aef3a72f1f1a2cec4e2 /pym/portage/tests/repoman
parent0f261405f63cd09639728da78e70a254cd3c5320 (diff)
downloadportage-68414e9ffe4c05a0a0e81734b80db61e2782937c.tar.gz
portage-68414e9ffe4c05a0a0e81734b80db61e2782937c.tar.bz2
portage-68414e9ffe4c05a0a0e81734b80db61e2782937c.zip
tests/repoman: use layout.conf update-changelog
Diffstat (limited to 'pym/portage/tests/repoman')
-rw-r--r--pym/portage/tests/repoman/test_simple.py18
1 files changed, 14 insertions, 4 deletions
diff --git a/pym/portage/tests/repoman/test_simple.py b/pym/portage/tests/repoman/test_simple.py
index 172c22d93..68681b33f 100644
--- a/pym/portage/tests/repoman/test_simple.py
+++ b/pym/portage/tests/repoman/test_simple.py
@@ -42,6 +42,15 @@ class SimpleRepomanTestCase(TestCase):
# $Header: $
""" % time.gmtime().tm_year
+ repo_configs = {
+ "test_repo": {
+ "layout.conf":
+ (
+ "update-changelog = true",
+ ),
+ }
+ }
+
profiles = (
("x86", "default/linux/x86/test_profile", "stable"),
)
@@ -91,7 +100,8 @@ class SimpleRepomanTestCase(TestCase):
("flag", "Description of how USE='flag' affects packages"),
)
- playground = ResolverPlayground(ebuilds=ebuilds, debug=debug)
+ playground = ResolverPlayground(ebuilds=ebuilds,
+ repo_configs=repo_configs, debug=debug)
settings = playground.settings
eprefix = settings["EPREFIX"]
eroot = settings["EROOT"]
@@ -128,13 +138,13 @@ class SimpleRepomanTestCase(TestCase):
("", git_cmd + ("commit", "-a", "-m", "add whole repo")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "2.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "2.ebuild")),
- ("", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 2")),
+ ("", repoman_cmd + ("commit", "-m", "bump to version 2")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "3.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "3.ebuild")),
- ("dev-libs", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 3")),
+ ("dev-libs", repoman_cmd + ("commit", "-m", "bump to version 3")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "4.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "4.ebuild")),
- ("dev-libs/A", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 4")),
+ ("dev-libs/A", repoman_cmd + ("commit", "-m", "bump to version 4")),
)
pythonpath = os.environ.get("PYTHONPATH")