summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-10-26 12:45:30 -0700
committerZac Medico <zmedico@gentoo.org>2010-10-26 12:45:30 -0700
commit4825a9b5cbc2e3173c4b9dcf2b6444811cca959c (patch)
treedc469a6883202be36f2c674da6b2d1a54272dbde /pym
parent0288c187e5f500e42a3981a7bffa00957309a8d1 (diff)
downloadportage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.tar.gz
portage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.tar.bz2
portage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.zip
ebuild(1): fix breakage for /var/db/pkg ebuilds
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/dbapi/vartree.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/pym/portage/dbapi/vartree.py b/pym/portage/dbapi/vartree.py
index 571b344f3..4b0b47ba0 100644
--- a/pym/portage/dbapi/vartree.py
+++ b/pym/portage/dbapi/vartree.py
@@ -421,7 +421,7 @@ class vardbapi(dbapi):
self.matchcache[mycat][mydep] = mymatch
return self.matchcache[mycat][mydep][:]
- def findname(self, mycpv):
+ def findname(self, mycpv, myrepo=None):
return self.getpath(str(mycpv), filename=catsplit(mycpv)[1]+".ebuild")
def flush_cache(self):