summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-09-30 21:22:49 -0700
committerZac Medico <zmedico@gentoo.org>2010-09-30 21:22:49 -0700
commit89b3d2359403a16f45ec353dd55b61c6a82659bc (patch)
tree872f561b48f9cad07dcbd9ead33aaa80f2f08306 /pym
parent801e22fae173d59c92199af0b26ce6c2b13c71fb (diff)
downloadportage-89b3d2359403a16f45ec353dd55b61c6a82659bc.tar.gz
portage-89b3d2359403a16f45ec353dd55b61c6a82659bc.tar.bz2
portage-89b3d2359403a16f45ec353dd55b61c6a82659bc.zip
Fix reversed porttrees findname2/findLicensePath.
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/dbapi/porttree.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/pym/portage/dbapi/porttree.py b/pym/portage/dbapi/porttree.py
index c63053749..317d4a01e 100644
--- a/pym/portage/dbapi/porttree.py
+++ b/pym/portage/dbapi/porttree.py
@@ -226,7 +226,7 @@ class portdbapi(dbapi):
x.sync()
def findLicensePath(self, license_name):
- for x in self.porttrees:
+ for x in reversed(self.porttrees):
license_path = os.path.join(x, "licenses", license_name)
if os.access(license_path, os.R_OK):
return license_path
@@ -312,7 +312,7 @@ class portdbapi(dbapi):
if mytree:
mytrees = [mytree]
else:
- mytrees = self.porttrees
+ mytrees = reversed(self.porttrees)
relative_path = mysplit[0] + _os.sep + psplit[0] + _os.sep + \
mysplit[1] + ".ebuild"