summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-07-04 22:49:04 +0000
committerZac Medico <zmedico@gentoo.org>2008-07-04 22:49:04 +0000
commitefead8fa199be63234d8b93e64e68797d3909aa9 (patch)
tree5b1d42fbc936e5fd2cbf5762ca7f24e37bc73161 /pym
parent91f77fbc590d73ea150f6f8abb3d218f268bf721 (diff)
downloadportage-efead8fa199be63234d8b93e64e68797d3909aa9.tar.gz
portage-efead8fa199be63234d8b93e64e68797d3909aa9.tar.bz2
portage-efead8fa199be63234d8b93e64e68797d3909aa9.zip
Make Binpkg inherit from EbuildBuildDir since it's going to hold
the build dir lock while it runs asynchronously. svn path=/main/trunk/; revision=10934
Diffstat (limited to 'pym')
-rw-r--r--pym/_emerge/__init__.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/pym/_emerge/__init__.py b/pym/_emerge/__init__.py
index 451e30d2e..bfae9e20a 100644
--- a/pym/_emerge/__init__.py
+++ b/pym/_emerge/__init__.py
@@ -2154,7 +2154,7 @@ class PackageUninstall(Task):
return e.status
return os.EX_OK
-class Binpkg(SlotObject):
+class Binpkg(EbuildBuildDir):
__slots__ = ("find_blockers",
"ldpath_mtimes", "logger", "opts",
@@ -2247,7 +2247,7 @@ class Binpkg(SlotObject):
}
try:
- build_dir.lock()
+ self.lock()
root_config = self.pkg.root_config
ebuild_path = os.path.join(infloc, pkg.pf + ".ebuild")
@@ -2347,7 +2347,7 @@ class Binpkg(SlotObject):
finally:
settings.pop("PORTAGE_BINPKG_FILE", None)
- build_dir.unlock()
+ self.unlock()
return os.EX_OK
class BinpkgFetcher(Task):