summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-09-21 19:56:26 +0000
committerZac Medico <zmedico@gentoo.org>2009-09-21 19:56:26 +0000
commitff3e65edee5959cd95f2268d7755d83a8f4a0d66 (patch)
treeaa50882a2a1c29a7b5e1cc50948a2d9da3943559 /pym
parentcade65d7ebc054a89f2d6b92b26dff8b748a8fbd (diff)
downloadportage-ff3e65edee5959cd95f2268d7755d83a8f4a0d66.tar.gz
portage-ff3e65edee5959cd95f2268d7755d83a8f4a0d66.tar.bz2
portage-ff3e65edee5959cd95f2268d7755d83a8f4a0d66.zip
Temporarily disable use of pty in py3k since it triggers an unresolved
issue, http://bugs.python.org/issue5380. With this workaround, portage.tests.ebuild.test_spawn.SpawnTestCase.testLogfile() does not raise IOError. svn path=/main/trunk/; revision=14362
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/__init__.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/pym/portage/__init__.py b/pym/portage/__init__.py
index e2fd1fbaa..dcd38bb89 100644
--- a/pym/portage/__init__.py
+++ b/pym/portage/__init__.py
@@ -3741,6 +3741,10 @@ class config(object):
# stop trying to use it after the first failure.
_disable_openpty = False
+if sys.hexversion >= 0x3000000:
+ # This is a temporary workaround for http://bugs.python.org/issue5380.
+ _disable_openpty = True
+
def _create_pty_or_pipe(copy_term_size=None):
"""
Try to create a pty and if then fails then create a normal