summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/ebuild.sh2
-rw-r--r--man/ebuild.53
2 files changed, 4 insertions, 1 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index ccd02cdb2..cfff8629b 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1797,7 +1797,7 @@ export S=${WORKDIR}/${P}
unset E_IUSE E_DEPEND E_RDEPEND E_PDEPEND
-for x in T P PN PV PVR PR A EBUILD EMERGE_FROM O PPID FILESDIR PORTAGE_TMPDIR; do
+for x in T P PN PV PVR PR CATEGORY A EBUILD EMERGE_FROM O PPID FILESDIR PORTAGE_TMPDIR; do
[[ ${!x-UNSET_VAR} != UNSET_VAR ]] && declare -r ${x}
done
# Need to be able to change D in dyn_preinst due to the IMAGE stuff
diff --git a/man/ebuild.5 b/man/ebuild.5
index fe66914bd..af8443df1 100644
--- a/man/ebuild.5
+++ b/man/ebuild.5
@@ -87,6 +87,9 @@ Contains the full package name \fI[PN]\-[PVR]\fR
.br
\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PF\fR=='\fIxfree-4.2.1-r2\fR'
.TP
+.B CATEGORY
+Contains the package category name.
+.TP
.B A
Contains all source files required for the package. This variable must
not be defined. It is autogenerated from the \fISRC_URI\fR variables.