summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman3
-rw-r--r--pym/repoman/checks.py4
2 files changed, 5 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index b296d675f..e6c281eac 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -72,7 +72,8 @@ from portage.output import bold, create_color_func, \
from portage.output import ConsoleStyleFile, StyleWriter
from portage.util import cmp_sort_key, writemsg_level
from portage.package.ebuild.digestgen import digestgen
-from portage.eapi import *
+from portage.eapi import eapi_has_src_uri_arrows, eapi_has_slot_deps, \
+ eapi_has_use_deps, eapi_has_strong_blocks, eapi_has_iuse_defaults
if sys.hexversion >= 0x3000000:
basestring = str
diff --git a/pym/repoman/checks.py b/pym/repoman/checks.py
index 67333419f..07f1deade 100644
--- a/pym/repoman/checks.py
+++ b/pym/repoman/checks.py
@@ -8,7 +8,9 @@ and correctness of an ebuild."""
import re
import time
import repoman.errors as errors
-from portage.eapi import *
+from portage.eapi import eapi_supports_prefix, eapi_has_implicit_rdepend, \
+ eapi_has_src_prepare_and_src_configure, eapi_has_dosed_dohard, \
+ eapi_exports_AA, eapi_exports_KV
class LineCheck(object):
"""Run a check on a line of an ebuild."""