summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pym/portage/dbapi/porttree.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/pym/portage/dbapi/porttree.py b/pym/portage/dbapi/porttree.py
index 84f8c196d..ec38e0850 100644
--- a/pym/portage/dbapi/porttree.py
+++ b/pym/portage/dbapi/porttree.py
@@ -511,7 +511,11 @@ class portdbapi(dbapi):
else:
mytrees = self.porttrees
for oroot in mytrees:
- for x in listdir(oroot+"/"+mycp, EmptyOnError=1, ignorecvs=1):
+ try:
+ file_list = os.listdir(os.path.join(oroot, mycp))
+ except OSError:
+ continue
+ for x in file_list:
if x.endswith(".ebuild"):
pf = x[:-7]
ps = pkgsplit(pf)