summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman10
1 files changed, 8 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index f2e520c6e..6194d1714 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1000,8 +1000,14 @@ for x in scanlist:
#for x in myaux[allvars.index("RESTRICT")].split():
# if x.startswith("no"):
# print "Bad RESTRICT value: %s" % x
-
- myaux["PROVIDE"] = portage.dep.use_reduce(portage.dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ try:
+ myaux["PROVIDE"] = portage.dep.use_reduce(
+ portage.dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ except portage.exception.InvalidDependString, e:
+ stats["PROVIDE.syntax"] = stats["PROVIDE.syntax"] + 1
+ fails["PROVIDE.syntax"].append(mykey+".ebuild PROVIDE: "+str(e))
+ del e
+ continue
myaux["PROVIDE"] = " ".join(portage.flatten(myaux["PROVIDE"]))
for myprovide in myaux["PROVIDE"].split():
prov_cp = portage.dep_getkey(myprovide)