summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman10
1 files changed, 5 insertions, 5 deletions
diff --git a/bin/repoman b/bin/repoman
index b30f6ab29..e281284ca 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -753,8 +753,8 @@ if vcs == "cvs":
if vcs == "svn":
svnstatus = os.popen("svn status").readlines()
- mychanged = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem and elem[:1] in "MR" ]
- mynew = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("A") ]
+ mychanged = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem and elem[:1] in "MR" ]
+ mynew = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("A") ]
if vcs:
new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
@@ -1711,9 +1711,9 @@ else:
if vcs == "svn":
if myautoadd:
svnstatus = os.popen("svn status").readlines()
- mychanged = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem and elem[:1] in "MR" ]
- mynew = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("A") ]
- myremoved = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("D") ]
+ mychanged = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem and elem[:1] in "MR" ]
+ mynew = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("A") ]
+ myremoved = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("D") ]
# in contrast to CVS, SVN expands nothing by default.
# bin_blobs historically
# were just there to see what files need to be checked for