summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/ebuild.sh4
-rw-r--r--doc/package/ebuild/eapi/4-python.docbook6
2 files changed, 10 insertions, 0 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index 173865cde..32dc64f0c 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -512,6 +512,10 @@ if ! has "$EBUILD_PHASE" clean cleanrm depend && \
[[ -n $EAPI ]] || EAPI=0
fi
+if has "${EAPI:-0}" 4-python; then
+ shopt -s globstar
+fi
+
if ! has "$EBUILD_PHASE" clean cleanrm ; then
if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
-f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
diff --git a/doc/package/ebuild/eapi/4-python.docbook b/doc/package/ebuild/eapi/4-python.docbook
index b4cbc1ad4..99ad197ac 100644
--- a/doc/package/ebuild/eapi/4-python.docbook
+++ b/doc/package/ebuild/eapi/4-python.docbook
@@ -31,6 +31,12 @@ official EAPI 4-python Specification</ulink>.
The "." character is allowed in USE flags.
</para>
</section>
+<section id='package-ebuild-eapi-4-python-globstar'>
+<title>globstar shell option enabled by default</title>
+<para>
+globstar shell option is enabled by default, which enables recursive expansion of ** pattern in pathname expansion context.
+</para>
+</section>
<section id='package-ebuild-eapi-4-python-repository-variable'>
<title>REPOSITORY Variable</title>
<para>