summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman26
1 files changed, 0 insertions, 26 deletions
diff --git a/bin/repoman b/bin/repoman
index b4b648271..738746e67 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -909,27 +909,6 @@ else:
#this can be problematic if xmllint changes their output
xmllint_capable=True
-
-def x11_deprecation_check(depstr):
- if depstr.find("virtual/x11") == -1:
- return False
- depsplit = depstr.split()
- ok_stack = []
- ok = False
- for token in depsplit:
- if token == "(":
- ok_stack.append(ok)
- ok = False
- elif token == ")":
- ok = ok_stack.pop()
- elif token == "||":
- ok = True
- else:
- ok = False
- if token.find("virtual/x11") != -1 and (not ok_stack or not ok_stack[-1]):
- return True
- return False
-
MISSING_QUOTES_ERROR = 'Unquoted Variable on line: %d'
NESTED_DIE_ERROR = 'Ebuild calls die in a subshell on line: %d'
REDUNDANT_CD_S_ERROR = 'Ebuild has redundant cd ${S} statement on line: %d'
@@ -1606,11 +1585,6 @@ for x in scanlist:
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
- if not baddepsyntax:
- if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
- stats["usage.obsolete"] += 1
- fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
-
# uselist checks - global
myuse = []
default_use = []