summaryrefslogtreecommitdiffstats
path: root/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/Makefile b/doc/Makefile
new file mode 100644
index 000000000..c829639ca
--- /dev/null
+++ b/doc/Makefile
@@ -0,0 +1,11 @@
+all: xhtml xhtml-nochunks
+
+XMLTO_FLAGS_man = -x custom.xsl
+man pdf txt xhtml xhtml-nochunks:
+ xmlto $@ $(XMLTO_FLAGS_$@) portage.docbook
+
+clean distclean:
+ rm -f *.1 *.html
+
+.PHONY: all clean distclean \
+ man pdf txt xhtml xhtml-nochunks