summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-03-25 09:49:42 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-03-25 09:49:42 +0100
commit00a2abd21f66c8bf69a28c4a30cf59a1d621e27c (patch)
tree920db395376d2902a9abd270cd641055236173bc /CMakeLists.txt
parentaf60e6a695a4adb94bd11522065ff4e34a7d7818 (diff)
downloadcolobot-00a2abd21f66c8bf69a28c4a30cf59a1d621e27c.tar.gz
colobot-00a2abd21f66c8bf69a28c4a30cf59a1d621e27c.tar.bz2
colobot-00a2abd21f66c8bf69a28c4a30cf59a1d621e27c.zip
Fixed GCC 4.6 compilation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 628b700..f58b654 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,7 +55,7 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
set(CXX11_FLAGS "-std=gnu++11")
elseif (GCC_VERSION VERSION_GREATER 4.6 OR GCC_VERSION VERSION_EQUAL 4.6)
message(STATUS "Detected GCC version 4.6+")
- set(CXX11_FLAGS "-std=c++0x")
+ set(CXX11_FLAGS "-std=c++0x -Doverride=")
else()
message(FATAL_ERROR "${PROJECT_NAME} requires GCC 4.6 or greater.")
endif()