summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-18 09:11:44 +0100
committerDidier Raboud <odyx@debian.org>2012-12-27 10:35:04 +0100
commit277629f9fec069afce32a21fd6baeb4f24d5784c (patch)
tree48c114f8e0a0d7ac7ec9112856e8f06dcbe24ef2 /CMakeLists.txt
parentc793d2d4c67a5556e39300988f42a630fc51e68d (diff)
downloadcolobot-277629f9fec069afce32a21fd6baeb4f24d5784c.tar.gz
colobot-277629f9fec069afce32a21fd6baeb4f24d5784c.tar.bz2
colobot-277629f9fec069afce32a21fd6baeb4f24d5784c.zip
Minor cmake grammar fix
It is redundant to have CMAKE_INSTALL_PREFIX in path definitions; drop them. Re-do a7d837460f5eeba060900031322d088ba330964c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a80e7d3..fe88d87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,11 +183,11 @@ if(${TESTS})
endif()
# Installation paths defined before compiling sources
-set(COLOBOT_INSTALL_BIN_DIR ${CMAKE_INSTALL_PREFIX}/games CACHE PATH "Colobot binary directory")
-set(COLOBOT_INSTALL_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/games/colobot CACHE PATH "Colobot shared data directory")
-set(COLOBOT_INSTALL_LIB_DIR ${CMAKE_INSTALL_PREFIX}/lib/colobot CACHE PATH "Colobot libraries directory")
-set(COLOBOT_INSTALL_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/colobot CACHE PATH "Colobot documentation directory")
-set(COLOBOT_INSTALL_I18N_DIR ${CMAKE_INSTALL_PREFIX}/share/locale CACHE PATH "Colobot translations directory")
+set(COLOBOT_INSTALL_BIN_DIR games CACHE PATH "Colobot binary directory")
+set(COLOBOT_INSTALL_DATA_DIR share/games/colobot CACHE PATH "Colobot shared data directory")
+set(COLOBOT_INSTALL_LIB_DIR lib/colobot CACHE PATH "Colobot libraries directory")
+set(COLOBOT_INSTALL_DOC_DIR share/doc/colobot CACHE PATH "Colobot documentation directory")
+set(COLOBOT_INSTALL_I18N_DIR share/locale CACHE PATH "Colobot translations directory")
# Subdirectory with sources
add_subdirectory(src bin)