summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-09-08 03:05:12 +0200
commit31c29ea482e3bb868e60a0de05d513511a942b97 (patch)
tree6101f1adeebbbf8c798cd51ec13e32549f14a44f /CMakeLists.txt
parent0b1e6949b0aaefd85f63c6a2d5f4d2b207e9b12d (diff)
downloadcolobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.gz
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.tar.bz2
colobot-31c29ea482e3bb868e60a0de05d513511a942b97.zip
CModelFile fixes; test framework
- fixes in CModelFile IO - added Google Test framework for automatic testing - rewrote modelfile_test in the new framework
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04b8912..2b9582a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,13 @@ set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -Wold-style-cast -std=gnu++0x")
set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
# Include cmake directory
-SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${colobot_SOURCE_DIR}/cmake")
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${colobot_SOURCE_DIR}/cmake")
+
+enable_testing()
+
+# Google Test library
+set(GTEST_DIR "${colobot_SOURCE_DIR}/lib/gtest")
+add_subdirectory(lib/gtest bin/test)
# Subdirectory with sources
add_subdirectory(src bin)