summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-06-24 13:07:33 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2013-06-24 14:16:39 +0200
commit3e989c96dff7889aff5b6476bf2a8fb9c541bd95 (patch)
treee09490d29a3d8259f2f7b123ea0c40f7518b8929 /CMakeLists.txt
parent78c167064bfffd30cb623fc82ca9b14d1fe36e7d (diff)
downloadcolobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.tar.gz
colobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.tar.bz2
colobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.zip
Fixed auto-detecting locale on Windows
* localename library is now used to determine the actual locale used * added patched version of FindGettext.cmake to fix installation path of translation files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e13d4dc..03338a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,7 @@ message(STATUS "Building Colobot \"${COLOBOT_VERSION_CODENAME}\" (${COLOBOT_VERS
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
# Include cmake directory with some additional scripts
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${colobot_SOURCE_DIR}/cmake")
+set(CMAKE_MODULE_PATH "${colobot_SOURCE_DIR}/cmake" ${CMAKE_MODULE_PATH})
# Auto-detect develpment build if not given
if(CMAKE_BUILD_TYPE AND NOT(DEV_BUILD))
@@ -145,7 +145,7 @@ find_package(GLEW REQUIRED)
if (${OPENAL_SOUND})
find_package(OpenAL REQUIRED)
- include("${colobot_SOURCE_DIR}/cmake/FindLibSndFile.cmake")
+ find_package(LibSndFile REQUIRED)
endif()
@@ -210,6 +210,13 @@ add_subdirectory(lib/clipboard)
##
+# Localename
+##
+set(LOCALENAME_INCLUDE_DIR ${colobot_SOURCE_DIR}/lib/localename)
+add_subdirectory(lib/localename)
+
+
+##
# Doxygen docs
##
@@ -278,7 +285,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Windows")
set(COLOBOT_INSTALL_BIN_DIR ${CMAKE_INSTALL_PREFIX}/ CACHE PATH "Colobot binary directory")
set(COLOBOT_INSTALL_LIB_DIR ${CMAKE_INSTALL_PREFIX}/ CACHE PATH "Colobot libraries directory")
set(COLOBOT_INSTALL_DATA_DIR ${CMAKE_INSTALL_PREFIX}/data CACHE PATH "Colobot shared data directory")
- set(COLOBOT_INSTALL_I18N_DIR ${CMAKE_INSTALL_PREFIX}/ CACHE PATH "Colobot translations directory")
+ set(COLOBOT_INSTALL_I18N_DIR ${CMAKE_INSTALL_PREFIX}/lang CACHE PATH "Colobot translations directory")
set(COLOBOT_INSTALL_DOC_DIR ${CMAKE_INSTALL_PREFIX}/doc CACHE PATH "Colobot documentation directory")
endif()
else()