summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-15 20:23:58 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-15 20:23:58 +0100
commit72ce040054f1ee20576094220075af4283674720 (patch)
treee59d2837a45ec81233423fa7aa47c4cfab4fabee /CMakeLists.txt
parent4a075edfec7cc0810c577b490e4a9231ebdd8afe (diff)
parenta4cf777fb8cb939db10998853fc9e40deb64aa8d (diff)
downloadcolobot-72ce040054f1ee20576094220075af4283674720.tar.gz
colobot-72ce040054f1ee20576094220075af4283674720.tar.bz2
colobot-72ce040054f1ee20576094220075af4283674720.zip
Merge branch 'master' into dev
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7090d2d..5873776 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,7 @@ find_package(SDL 1.2.10 REQUIRED)
find_package(SDL_image 1.2 REQUIRED)
find_package(SDL_ttf 2.0 REQUIRED)
find_package(PNG 1.2 REQUIRED)
+find_package(LTDL 2.4.2 REQUIRED)
set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_MULTITHREADED ON)
@@ -128,8 +129,12 @@ endif()
if(${TESTS})
# Google Test library
- set(GTEST_DIR "${colobot_SOURCE_DIR}/lib/gtest")
- add_subdirectory(lib/gtest bin/test)
+ find_path(GTEST_SRC_DIR NAMES src/gtest.cc src/gtest-all.cc PATHS /usr/src/ PATH_SUFFIXES gtest)
+ if(GTEST_SRC_DIR)
+ add_subdirectory(${GTEST_SRC_DIR} bin/test)
+ else()
+ add_subdirectory(lib/gtest bin/test)
+ endif()
endif()
# Subdirectory with sources