summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-06-16 21:39:21 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2013-06-16 21:54:36 +0200
commit7874aca10ce6da823f88e8aabe4a0ea6431cc480 (patch)
tree6ab2e5e4dd0dcb4263701ca44a1edf08b0f101f7 /CMakeLists.txt
parent7cf88118885699a23daa4768285d512fc06d5a2a (diff)
downloadcolobot-7874aca10ce6da823f88e8aabe4a0ea6431cc480.tar.gz
colobot-7874aca10ce6da823f88e8aabe4a0ea6431cc480.tar.bz2
colobot-7874aca10ce6da823f88e8aabe4a0ea6431cc480.zip
Enhanced logging, option to auto-start mission
* added logging of application events * changed debug mode flag to independent debug modes * added option to auto-start mission (load a mission immediately after startup) * removed "enum value out of range" prints * some refactoring
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cb7e70..ed6008a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,8 @@ option(INSTALL_DOCS "Install Doxygen-generated documentation" OFF)
# Build openal sound support
option(OPENAL_SOUND "Build openal sound support" OFF)
+# Change to false in case static boost libraries are not available
+option(STATIC_BOOST "Link with static boost libraries" ON)
##
# Searching for packages
@@ -110,9 +112,9 @@ find_package(SDL_ttf 2.0 REQUIRED)
find_package(PNG 1.2 REQUIRED)
find_package(Gettext REQUIRED)
-set(Boost_USE_STATIC_LIBS ON)
-set(Boost_USE_MULTITHREADED ON)
-set(Boost_USE_STATIC_RUNTIME OFF)
+set(Boost_USE_STATIC_LIBS ${STATIC_BOOST})
+set(Boost_USE_MULTITHREADED ON)
+set(Boost_USE_STATIC_RUNTIME OFF)
set(Boost_ADDITIONALVERSION "1.51" "1.51.0")
find_package(Boost COMPONENTS system filesystem regex REQUIRED)
@@ -184,7 +186,7 @@ endif()
##
# Clipboard support
##
-set(CLIPBOARD_DIR ${colobot_SOURCE_DIR}/lib/clipboard/include)
+set(CLIPBOARD_INCLUDE_DIR ${colobot_SOURCE_DIR}/lib/clipboard/include)
add_subdirectory(${colobot_SOURCE_DIR}/lib/clipboard bin/clipboard)