summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-19 16:54:58 +0100
committerDidier Raboud <odyx@debian.org>2012-12-19 16:55:00 +0100
commit7e9ef0c042fd14373a129ca8a5ac94e9679daee9 (patch)
treeb34f2c5b0beb3897ba187734bed0679c1e70f909 /CMakeLists.txt
parent3c976c040b48caa9f3e75d12a6502e39193ce9a6 (diff)
downloadcolobot-7e9ef0c042fd14373a129ca8a5ac94e9679daee9.tar.gz
colobot-7e9ef0c042fd14373a129ca8a5ac94e9679daee9.tar.bz2
colobot-7e9ef0c042fd14373a129ca8a5ac94e9679daee9.zip
Put common CXX flags in common variables
CMAKE_CXX_FLAGS is taken into account in all builds; build-type-specific flags are appended to it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96ae055..78298a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,8 +22,9 @@ endif(NOT CMAKE_BUILD_TYPE)
# Global compile flags
# These are specific to GCC/MinGW; for other compilers, change as necessary
-set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -Wold-style-cast -std=gnu++0x")
-set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0")
# Asserts can be enabled/disabled regardless of build type
option(ASSERTS "Enable assert()s" ON)