summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-03-27 20:53:28 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-03-27 20:54:04 +0100
commit8301a3639be3ffbc6963206aa0634464d943229a (patch)
tree08342784bae736d678afa758df7f2d3e14d0485f /CMakeLists.txt
parent672abbbbca5bd12441a2e3ebca0d04bfa529e84f (diff)
downloadcolobot-8301a3639be3ffbc6963206aa0634464d943229a.tar.gz
colobot-8301a3639be3ffbc6963206aa0634464d943229a.tar.bz2
colobot-8301a3639be3ffbc6963206aa0634464d943229a.zip
Moved boost flags to CMakeLists
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f58b654..38458bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,10 +67,15 @@ else()
"Supported compilers at this time are GCC 4.6+ and clang.")
endif()
+
# Global compile flags
# These are specific to GCC/MinGW/clang; for other compilers, change as necessary
# The flags are used throughout src/ and test/ subdirs
-set(COLOBOT_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wold-style-cast ${CXX11_FLAGS}")
+
+# Special flags for boost
+set(Boost_FLAGS "-DBOOST_NO_SCOPED_ENUMS -DBOOST_NO_CXX11_SCOPED_ENUMS")
+
+set(COLOBOT_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wold-style-cast ${CXX11_FLAGS} ${Boost_FLAGS}")
set(COLOBOT_CXX_FLAGS_RELEASE "-O2")
set(COLOBOT_CXX_FLAGS_DEBUG "-g -O0")