summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-06-22 22:32:20 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2013-06-22 22:33:06 +0200
commit8cb2e54de844accbd831a167233e8348b175d930 (patch)
tree1dd041e4deedb2ad9f5ccb09f9ae6c3dbda2392d /CMakeLists.txt
parenta224ae4408a60a3385913af69906743b7f8f6790 (diff)
downloadcolobot-8cb2e54de844accbd831a167233e8348b175d930.tar.gz
colobot-8cb2e54de844accbd831a167233e8348b175d930.tar.bz2
colobot-8cb2e54de844accbd831a167233e8348b175d930.zip
Futher changes to CMake options
* OpenAL sound is now enabled by default * Boost is linked dynamically by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acacda9..e13d4dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,11 +114,14 @@ option(DESKTOP "Generate desktop files, manpages, etc" ON)
# Doxygen docs are optional for installation
option(INSTALL_DOCS "Install Doxygen-generated documentation" OFF)
-# Build openal sound support
-option(OPENAL_SOUND "Build openal sound support" OFF)
+# Build OpenAL sound support
+option(OPENAL_SOUND "Build OpenAL sound support" ON)
# Change to false in case static boost libraries are not available
-option(STATIC_BOOST "Link with static boost libraries" ON)
+option(BOOST_STATIC "Link with static boost libraries" OFF)
+
+# This is useful on Windows, if linking against standard GLEW dll fails
+option(GLEW_STATIC "Link statically with GLEW" OFF)
##
# Searching for packages
@@ -131,16 +134,13 @@ find_package(SDL_ttf 2.0 REQUIRED)
find_package(PNG 1.2 REQUIRED)
find_package(Gettext REQUIRED)
-set(Boost_USE_STATIC_LIBS ${STATIC_BOOST})
+set(Boost_USE_STATIC_LIBS ${BOOST_STATIC})
set(Boost_USE_MULTITHREADED ON)
set(Boost_USE_STATIC_RUNTIME OFF)
set(Boost_ADDITIONALVERSION "1.51" "1.51.0")
find_package(Boost COMPONENTS system filesystem regex REQUIRED)
-# This is useful on Windows, if linking against standard GLEW dll fails
-option(GLEW_STATIC "Link statically with GLEW" OFF)
-
find_package(GLEW REQUIRED)
if (${OPENAL_SOUND})