summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-07-01 01:37:30 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-07-01 01:37:30 +0200
commit9bd4ec03b272e7925b11c3efc2bd8460894ea589 (patch)
treef97339cd526e4240d2fc5932a263fb84cbec93d8 /CMakeLists.txt
parent5bbf897fb1d54df0dc84a0cea35775083591b88f (diff)
downloadcolobot-9bd4ec03b272e7925b11c3efc2bd8460894ea589.tar.gz
colobot-9bd4ec03b272e7925b11c3efc2bd8460894ea589.tar.bz2
colobot-9bd4ec03b272e7925b11c3efc2bd8460894ea589.zip
CDevice interface and stub of implementation
- added CDevice abstract interface - began implementation of CGLDevice - added stub for Texture struct - created CGLDeviceConfig - changed particule -> particle & other minor changes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0fc02e..3a50bcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ find_package(OpenGL REQUIRED)
find_package(SDL REQUIRED)
find_package(SDL_image REQUIRED)
+# TODO: check for SDL version. Should be >= 1.2.10
+
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)