summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-25 19:59:17 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-25 19:59:17 +0200
commitb08a63790c0fbeacb3f96a74e3eb15abe8c70dab (patch)
tree7260140ae1ea308bd256370c6fcbbc57dbd13441 /CMakeLists.txt
parentf58918031c001a0159eaf8f18d4e451e70089d30 (diff)
downloadcolobot-b08a63790c0fbeacb3f96a74e3eb15abe8c70dab.tar.gz
colobot-b08a63790c0fbeacb3f96a74e3eb15abe8c70dab.tar.bz2
colobot-b08a63790c0fbeacb3f96a74e3eb15abe8c70dab.zip
SDL project
- added (very basic) SDL template in CApplication and CEngine - split project into two targets: colobot_old (dependent on DirectX and WinAPI) and colobot_new (dependent on SDL and OpenGL) - moved sound.h/cpp to old/ and created new template in Snd namespace - added platform-independent dialog boxes in app/system.h/cpp
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02016af..ae0231d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,9 +1,15 @@
-# CMake project file for compiling with MinGW
+# CMake project file for compiling with GCC/MinGW
cmake_minimum_required(VERSION 2.8)
-project(colobot CXX)
+project(colobot C CXX)
+# Required packages
+find_package(OpenGL REQUIRED)
+find_package(SDL REQUIRED)
+find_package(SDL_image REQUIRED)
+
+# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
# Currently compiles only with -fpermissive
@@ -11,4 +17,5 @@ set(CMAKE_BUILD_TYPE debug)
set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+# Subdirectory with sources
add_subdirectory(src bin)