summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZaba999 <zaba.marcin@gmail.com>2012-07-04 22:14:28 +0200
committerZaba999 <zaba.marcin@gmail.com>2012-07-04 22:14:28 +0200
commitdbd62c96aa351dc1c21e3392348edda2eb012e09 (patch)
treee9255406b53ac027e841a5d25265b2c78cf7e3e8 /CMakeLists.txt
parentfd6147bea012093ce0f70d843eb6732c581d2a4f (diff)
downloadcolobot-dbd62c96aa351dc1c21e3392348edda2eb012e09.tar.gz
colobot-dbd62c96aa351dc1c21e3392348edda2eb012e09.tar.bz2
colobot-dbd62c96aa351dc1c21e3392348edda2eb012e09.zip
Fixed code compilation without fpermissive flag.
Removed Winapi, but now library don't work - work in progress. Some translations.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d24e0a..5ca52f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,8 @@ find_package(SDL_image REQUIRED)
set(CMAKE_BUILD_TYPE debug)
# Global compile flags
-set(CMAKE_CXX_FLAGS_RELEASE "-O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0")
+set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall")
+set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0 -Wall")
# Subdirectory with sources
add_subdirectory(src bin)