summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-17 10:11:56 +0100
committerDidier Raboud <odyx@debian.org>2012-12-17 10:15:14 +0100
commite062b74a3a0081e07527ffdbf1256d775a41bce1 (patch)
tree0ccd65a52d1853db4517c9f6a52b836889cb0b17 /CMakeLists.txt
parent5a78b26f758ed0fa4b603ef086d21965e15010cd (diff)
downloadcolobot-e062b74a3a0081e07527ffdbf1256d775a41bce1.tar.gz
colobot-e062b74a3a0081e07527ffdbf1256d775a41bce1.tar.bz2
colobot-e062b74a3a0081e07527ffdbf1256d775a41bce1.zip
Install libCBot to a private directory
closes #90 - Make it configurable; - Move stanzas above the src directory inclusion, otherwise the value doesn't propagate.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5238c1e..b60ac93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -159,9 +159,11 @@ if(${TESTS})
endif()
+# TODO: provide data files as git submodule
+set(COLOBOT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/games/colobot CACHE PATH "Colobot shared data directory")
+set(COLOBOT_LIB_DIR ${CMAKE_INSTALL_PREFIX}/lib/colobot CACHE PATH "Colobot libraries directory")
+
# Subdirectory with sources
add_subdirectory(src bin)
-# TODO: provide data files as git submodule
-set(COLOBOT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/games/colobot CACHE PATH "Colobot shared data directory")
install(DIRECTORY ../data DESTINATION ${COLOBOT_DATA_DIR})