summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-30 00:12:04 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-30 00:12:04 +0200
commite37019943cb77d8c0735b330339a139430202fd8 (patch)
tree705c83d2774db76c58dd9853b2beb25fa03968d7 /CMakeLists.txt
parentdb5c6b5e45134f3cce21ee7b9b5ba4ca8d1e909c (diff)
downloadcolobot-e37019943cb77d8c0735b330339a139430202fd8.tar.gz
colobot-e37019943cb77d8c0735b330339a139430202fd8.tar.bz2
colobot-e37019943cb77d8c0735b330339a139430202fd8.zip
Event handling, CApplication and switch to c++-11
- added/changed event structs and event queue in common/event.h - added event handling and some minor functions in CApplication - switched to --std=c++11 because of union in Event struct
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d24e0a..b825022 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,8 @@ find_package(SDL_image REQUIRED)
set(CMAKE_BUILD_TYPE debug)
# Global compile flags
-set(CMAKE_CXX_FLAGS_RELEASE "-O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0")
+set(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -w -g -O0")
# Subdirectory with sources
add_subdirectory(src bin)