summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:39:31 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:39:31 +0200
commite738c55b73a8d635cac34fb3c37f3758ca4f1671 (patch)
tree3f12e1f4389bd676ce956baaf2dc841e311c3d2f /CMakeLists.txt
parentc2a7375788aea0cf1c0f4c45e4823a8a9a85264d (diff)
downloadcolobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.tar.gz
colobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.tar.bz2
colobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.zip
Removed old code and build target
- removed directory with old target - changed CMakeLists.txt to new target only and temporarily commented out reference to CBot - updated README
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae0231d..2d24e0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,10 +12,9 @@ find_package(SDL_image REQUIRED)
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
-# Currently compiles only with -fpermissive
-
-set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+# Global compile flags
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0")
# Subdirectory with sources
add_subdirectory(src bin)