summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier 'OdyX' Raboud <didier@raboud.com>2013-10-31 11:56:32 +0100
committerDidier 'OdyX' Raboud <didier@raboud.com>2013-11-13 09:35:32 +0100
commitffdba25411e544efd04b51c54f8b23cdd518b554 (patch)
treed0c6e0f3b59127812ba6d1745aa91201d756219a /CMakeLists.txt
parentaeefdbd1bed4d0670b1e860e900eebb9d70b3543 (diff)
downloadcolobot-ffdba25411e544efd04b51c54f8b23cdd518b554.tar.gz
colobot-ffdba25411e544efd04b51c54f8b23cdd518b554.tar.bz2
colobot-ffdba25411e544efd04b51c54f8b23cdd518b554.zip
Add MacOSX bundle-specific installation paths
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43b4a8f..9af0aef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,6 +309,12 @@ if(PLATFORM_WINDOWS)
set(COLOBOT_INSTALL_I18N_DIR ${CMAKE_INSTALL_PREFIX}/lang CACHE PATH "Colobot translations directory")
set(COLOBOT_INSTALL_DOC_DIR ${CMAKE_INSTALL_PREFIX}/doc CACHE PATH "Colobot documentation directory")
endif()
+elseif(PLATFORM_MACOSX)
+ set(COLOBOT_INSTALL_BIN_DIR ${CMAKE_INSTALL_PREFIX}/Contents/MacOS CACHE PATH "Colobot binary directory")
+ set(COLOBOT_INSTALL_LIB_DIR ${CMAKE_INSTALL_PREFIX}/Contents/libs CACHE PATH "Colobot libraries directory")
+ set(COLOBOT_INSTALL_DATA_DIR ${CMAKE_INSTALL_PREFIX}/Contents/Resources CACHE PATH "Colobot shared data directory")
+ set(COLOBOT_INSTALL_I18N_DIR ${CMAKE_INSTALL_PREFIX}/Contents/Resources/i18n CACHE PATH "Colobot translations directory")
+ set(COLOBOT_INSTALL_DOC_DIR ${CMAKE_INSTALL_PREFIX}/Contents/Resources/doc CACHE PATH "Colobot documentation directory")
else()
set(COLOBOT_INSTALL_BIN_DIR ${CMAKE_INSTALL_PREFIX}/games CACHE PATH "Colobot binary directory")
set(COLOBOT_INSTALL_LIB_DIR ${CMAKE_INSTALL_PREFIX}/lib/colobot CACHE PATH "Colobot libraries directory")