summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-06-24 13:07:33 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2013-06-24 14:16:39 +0200
commit3e989c96dff7889aff5b6476bf2a8fb9c541bd95 (patch)
treee09490d29a3d8259f2f7b123ea0c40f7518b8929 /src/CMakeLists.txt
parent78c167064bfffd30cb623fc82ca9b14d1fe36e7d (diff)
downloadcolobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.tar.gz
colobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.tar.bz2
colobot-3e989c96dff7889aff5b6476bf2a8fb9c541bd95.zip
Fixed auto-detecting locale on Windows
* localename library is now used to determine the actual locale used * added patched version of FindGettext.cmake to fix installation path of translation files
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7c02aa1..6f93532 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -185,6 +185,7 @@ ${OPENAL_SRC}
set(LIBS
CBot
clipboard
+localename
${SDL_LIBRARY}
${SDLIMAGE_LIBRARY}
${SDLTTF_LIBRARY}
@@ -214,6 +215,7 @@ ${PNG_INCLUDE_DIRS}
${GLEW_INCLUDE_PATH}
${Boost_INCLUDE_DIRS}
${LIBSNDFILE_INCLUDE_DIR}
+${LOCALENAME_INCLUDE_DIR}
${OPTIONAL_INCLUDE_DIRS}
${CLIPBOARD_INCLUDE_DIR}
)