summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-12-19 08:50:46 +0100
committerDidier Raboud <odyx@debian.org>2012-12-19 08:50:46 +0100
commitc6c57c0e99ce1d89eb0804ce96a3ce3f40d0ef61 (patch)
treed741264d93a0adf2130547d83760d2dab02fc916 /src/CMakeLists.txt
parent22ac35cd88e9b3c0fa1589274c0267225784c421 (diff)
downloadcolobot-c6c57c0e99ce1d89eb0804ce96a3ce3f40d0ef61.tar.gz
colobot-c6c57c0e99ce1d89eb0804ce96a3ce3f40d0ef61.tar.bz2
colobot-c6c57c0e99ce1d89eb0804ce96a3ce3f40d0ef61.zip
Fix RPath in installed colobot
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7f3441..7096bff 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -196,4 +196,4 @@ add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
install(TARGETS colobot RUNTIME DESTINATION games/)
-set_target_properties(colobot PROPERTIES INSTALL_RPATH ${COLOBOT_LIB_DIR})
+set_target_properties(colobot PROPERTIES INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${COLOBOT_LIB_DIR}")