summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-20 00:23:12 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-20 00:23:12 +0100
commitf77734e01c85aded92cf5fdc1e7038658e6aaf29 (patch)
tree27e84055413faaeeba630f305d92296df6d7eee2 /src/CMakeLists.txt
parente3db0b0c1970d3de8f86a4568dfcd1340f06b58b (diff)
downloadcolobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.tar.gz
colobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.tar.bz2
colobot-f77734e01c85aded92cf5fdc1e7038658e6aaf29.zip
Installation path fixes and CMakeLists refactoring
make && make install should now give a working installation.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7096bff..be50e94 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -195,5 +195,5 @@ add_executable(colobot ${SOURCES})
target_link_libraries(colobot ${LIBS})
-install(TARGETS colobot RUNTIME DESTINATION games/)
-set_target_properties(colobot PROPERTIES INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${COLOBOT_LIB_DIR}")
+install(TARGETS colobot RUNTIME DESTINATION ${COLOBOT_INSTALL_BIN_DIR})
+set_target_properties(colobot PROPERTIES INSTALL_RPATH ${COLOBOT_INSTALL_LIB_DIR})