summaryrefslogtreecommitdiffstats
path: root/src/common/test/CMakeLists.txt
diff options
context:
space:
mode:
authorZaba999 <qrwfw5rp>2012-09-28 21:03:28 +0200
committerZaba999 <qrwfw5rp>2012-09-28 21:03:28 +0200
commitdf4e3dfb6e623889757afe79fc4dfd29ae85748e (patch)
tree7985de535cce2456ccfe7716da206c9b0b1cde0f /src/common/test/CMakeLists.txt
parent38ebf4c3989a600cf5e9cf89be648d9b3373bc7c (diff)
downloadcolobot-df4e3dfb6e623889757afe79fc4dfd29ae85748e.tar.gz
colobot-df4e3dfb6e623889757afe79fc4dfd29ae85748e.tar.bz2
colobot-df4e3dfb6e623889757afe79fc4dfd29ae85748e.zip
Small fix in profile + profile_test rewritten to gtest.
Diffstat (limited to 'src/common/test/CMakeLists.txt')
-rw-r--r--src/common/test/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index a1a7a50..7936862 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -1,14 +1,20 @@
cmake_minimum_required(VERSION 2.8)
set(CMAKE_BUILD_TYPE debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+
+include_directories(
+.
+../..
+../../..
+${GTEST_DIR}/include
+)
-include_directories("../../")
-include_directories("../../../")
add_executable(image_test ../image.cpp image_test.cpp)
-target_link_libraries(image_test -lpng -lSDL -lSDL_image)
+target_link_libraries(image_test ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${PNG_LIBRARIES})
-add_executable(profile_test ../profile.cpp profile_test.cpp)
+add_executable(profile_test ../profile.cpp ../logger.cpp profile_test.cpp)
+target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
add_test(profile_test ./profile_test)