summaryrefslogtreecommitdiffstats
path: root/src/graphics/opengl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-07-05 23:47:29 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-07-05 23:47:29 +0200
commite8c9945e13fca88a6f8232838682df0654437f3e (patch)
tree2a0974afe8cdb30d7862e189d4d9adc5d6d59849 /src/graphics/opengl/test/CMakeLists.txt
parentaf3057df7eb41973349b407539846f17d9094c21 (diff)
downloadcolobot-e8c9945e13fca88a6f8232838682df0654437f3e.tar.gz
colobot-e8c9945e13fca88a6f8232838682df0654437f3e.tar.bz2
colobot-e8c9945e13fca88a6f8232838682df0654437f3e.zip
Fixed bug with texturing
- moved creation-time tex params to Gfx::TextureCreateParams - fixed bug with texture creation - added simple test for multitexturing
Diffstat (limited to 'src/graphics/opengl/test/CMakeLists.txt')
-rw-r--r--src/graphics/opengl/test/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/graphics/opengl/test/CMakeLists.txt b/src/graphics/opengl/test/CMakeLists.txt
new file mode 100644
index 0000000..ce2a83f
--- /dev/null
+++ b/src/graphics/opengl/test/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required(VERSION 2.8)
+
+find_package(OpenGL REQUIRED)
+find_package(SDL REQUIRED)
+find_package(SDL_image REQUIRED)
+find_package(PNG REQUIRED)
+
+set(CMAKE_BUILD_TYPE debug)
+set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
+
+
+set(SOURCES
+../gldevice.cpp
+../../common/device.cpp
+../../../common/logger.cpp
+../../../common/image.cpp
+texture_test.cpp
+)
+
+include_directories(../../../)
+
+set(LIBS
+${SDL_LIBRARY}
+${SDLIMAGE_LIBRARY}
+${OPENGL_LIBRARY}
+${PNG_LIBRARIES}
+)
+
+add_executable(texture_test ${SOURCES})
+
+target_link_libraries(texture_test ${LIBS})