summaryrefslogtreecommitdiffstats
path: root/src/graphics/opengl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-07-18 19:08:34 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-07-18 19:08:34 +0200
commitf364f378cf497faf61d78aadd8f1aebce678c0ec (patch)
tree02de3c2415247a7856a02657b1eff9500b5d1e50 /src/graphics/opengl/test/CMakeLists.txt
parent68a7bafe37adef0e5ef12c2d0e8461a21e05363b (diff)
downloadcolobot-f364f378cf497faf61d78aadd8f1aebce678c0ec.tar.gz
colobot-f364f378cf497faf61d78aadd8f1aebce678c0ec.tar.bz2
colobot-f364f378cf497faf61d78aadd8f1aebce678c0ec.zip
Fixed OpenGL transformations
- fixed wrong order of transformations - added transform_test
Diffstat (limited to 'src/graphics/opengl/test/CMakeLists.txt')
-rw-r--r--src/graphics/opengl/test/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/graphics/opengl/test/CMakeLists.txt b/src/graphics/opengl/test/CMakeLists.txt
index 4242c77..58c4714 100644
--- a/src/graphics/opengl/test/CMakeLists.txt
+++ b/src/graphics/opengl/test/CMakeLists.txt
@@ -48,6 +48,16 @@ set(MODEL_SOURCES
model_test.cpp
)
+set(TRANSFORM_SOURCES
+../gldevice.cpp
+../../common/device.cpp
+../../../common/logger.cpp
+../../../common/image.cpp
+../../../common/iman.cpp
+../../../app/system.cpp
+transform_test.cpp
+)
+
include_directories(../../../ ${CMAKE_CURRENT_BINARY_DIR})
set(LIBS
@@ -63,3 +73,6 @@ target_link_libraries(texture_test ${LIBS})
add_executable(model_test ${MODEL_SOURCES})
target_link_libraries(model_test ${LIBS})
+
+add_executable(transform_test ${TRANSFORM_SOURCES})
+target_link_libraries(transform_test ${LIBS})