summaryrefslogtreecommitdiffstats
path: root/src/math/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-15 16:58:04 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-15 16:58:04 +0200
commitb8027ce9a7f050b95846a668a02f5801331e127f (patch)
treea41bdf9e5b5431c9a4469bd54ba102cc438fe3f9 /src/math/test/CMakeLists.txt
parentb735913debff93c1a6444ec731cd4bf99ae2a5c2 (diff)
downloadcolobot-b8027ce9a7f050b95846a668a02f5801331e127f.tar.gz
colobot-b8027ce9a7f050b95846a668a02f5801331e127f.tar.bz2
colobot-b8027ce9a7f050b95846a668a02f5801331e127f.zip
Tests and fixes in math geometry.h module
Diffstat (limited to 'src/math/test/CMakeLists.txt')
-rw-r--r--src/math/test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/math/test/CMakeLists.txt b/src/math/test/CMakeLists.txt
index 3d52dd9..e94f765 100644
--- a/src/math/test/CMakeLists.txt
+++ b/src/math/test/CMakeLists.txt
@@ -5,7 +5,7 @@ set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
add_executable(matrix_test matrix_test.cpp)
add_executable(vector_test vector_test.cpp)
-add_executable(geometry_test geometry_test.cpp)
+add_executable(geometry_test geometry_test.cpp ../old/math3d.cpp ../old/d3dmath.cpp ../../graphics/d3d/d3dutil.cpp)
enable_testing()
@@ -13,6 +13,10 @@ add_test(matrix_test ./matrix_test)
add_test(vector_test ./vector_test)
add_test(geometry_test ./geometry_test)
+include_directories(c:/dxsdk/include)
+
+add_definitions(-DSTRICT -DD3D_OVERLOADS)
+
# 'make check' will compile the required test programs
# Note that 'make test' will still fail without compiled programs
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} DEPENDS matrix_test vector_test)