summaryrefslogtreecommitdiffstats
path: root/src/old/planet.h
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:39:31 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-26 23:39:31 +0200
commite738c55b73a8d635cac34fb3c37f3758ca4f1671 (patch)
tree3f12e1f4389bd676ce956baaf2dc841e311c3d2f /src/old/planet.h
parentc2a7375788aea0cf1c0f4c45e4823a8a9a85264d (diff)
downloadcolobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.tar.gz
colobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.tar.bz2
colobot-e738c55b73a8d635cac34fb3c37f3758ca4f1671.zip
Removed old code and build target
- removed directory with old target - changed CMakeLists.txt to new target only and temporarily commented out reference to CBot - updated README
Diffstat (limited to 'src/old/planet.h')
-rw-r--r--src/old/planet.h76
1 files changed, 0 insertions, 76 deletions
diff --git a/src/old/planet.h b/src/old/planet.h
deleted file mode 100644
index 36f5586..0000000
--- a/src/old/planet.h
+++ /dev/null
@@ -1,76 +0,0 @@
-// * This file is part of the COLOBOT source code
-// * Copyright (C) 2001-2008, Daniel ROUX & EPSITEC SA, www.epsitec.ch
-// *
-// * This program is free software: you can redistribute it and/or modify
-// * it under the terms of the GNU General Public License as published by
-// * the Free Software Foundation, either version 3 of the License, or
-// * (at your option) any later version.
-// *
-// * This program is distributed in the hope that it will be useful,
-// * but WITHOUT ANY WARRANTY; without even the implied warranty of
-// * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-// * GNU General Public License for more details.
-// *
-// * You should have received a copy of the GNU General Public License
-// * along with this program. If not, see http://www.gnu.org/licenses/.
-
-// planet.h
-
-#pragma once
-
-
-#include "common/event.h"
-#include "math/point.h"
-
-
-class CInstanceManager;
-class CD3DEngine;
-
-
-
-const int MAXPLANET = 10;
-
-struct Planet
-{
- char bUsed; // true -> planet exists
- Math::Point start; // initial position in degrees
- Math::Point angle; // current position in degrees
- float dim; // dimensions (0..1)
- float speed; // speed
- float dir; // direction in the sky
- char name[20]; // name of the texture
- Math::Point uv1, uv2; // texture mapping
- char bTGA; // texture .TGA
-};
-
-
-
-
-class CPlanet
-{
-public:
- CPlanet(CInstanceManager* iMan, CD3DEngine* engine);
- ~CPlanet();
-
- void Flush();
- bool EventProcess(const Event &event);
- bool Create(int mode, Math::Point start, float dim, float speed, float dir, char *name, Math::Point uv1, Math::Point uv2);
- bool PlanetExist();
- void LoadTexture();
- void Draw();
- void SetMode(int mode);
- int RetMode();
-
-protected:
- bool EventFrame(const Event &event);
-
-protected:
- CInstanceManager* m_iMan;
- CD3DEngine* m_engine;
-
- float m_time;
- int m_mode;
- Planet m_planet[2][MAXPLANET];
- bool m_bPlanetExist;
-};
-