summaryrefslogtreecommitdiffstats
path: root/src/plugins/sound/oalsound/CMakeLists.txt
diff options
context:
space:
mode:
authorerihel <erihel@gmail.com>2012-07-04 19:38:18 +0200
committererihel <erihel@gmail.com>2012-07-04 19:38:18 +0200
commitecab9761d46754cd8d7a513a8ac16a8b88499d55 (patch)
treefeca28addca2bf6616c6e6b83a365879088f9986 /src/plugins/sound/oalsound/CMakeLists.txt
parent092e4ae75e28fca8cf13d0315eb3923ba1c27133 (diff)
downloadcolobot-ecab9761d46754cd8d7a513a8ac16a8b88499d55.tar.gz
colobot-ecab9761d46754cd8d7a513a8ac16a8b88499d55.tar.bz2
colobot-ecab9761d46754cd8d7a513a8ac16a8b88499d55.zip
* Added OpenAL sound plugin
Plugin needs some more work and tests. It doesn't support playing music yet as sound interface is propably going to change a bit.
Diffstat (limited to 'src/plugins/sound/oalsound/CMakeLists.txt')
-rw-r--r--src/plugins/sound/oalsound/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/plugins/sound/oalsound/CMakeLists.txt b/src/plugins/sound/oalsound/CMakeLists.txt
new file mode 100644
index 0000000..6056590
--- /dev/null
+++ b/src/plugins/sound/oalsound/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 2.8)
+
+set(SOURCES
+ alsound.cpp
+ buffer.cpp
+ channel.cpp
+ ../../../common/logger.cpp
+)
+
+SET (CMAKE_CXX_FLAGS "-Wall -g -std=c++0x")
+
+include(FindPkgConfig)
+include(FindOpenAL)
+pkg_check_modules(OPENAL_LIB REQUIRED openal)
+
+set(OPENAL_LIBRARIES
+ openal
+ alut
+)
+
+
+include_directories(../../..)
+include_directories(.)
+add_library(openalsound SHARED ${SOURCES})
+target_link_libraries(openalsound ${OPENAL_LIBRARIES})