summaryrefslogtreecommitdiffstats
path: root/src/plugins/test/CMakeLists.txt
diff options
context:
space:
mode:
authorerihel <erihel@gmail.com>2012-08-12 15:00:37 +0200
committererihel <erihel@gmail.com>2012-08-12 15:00:37 +0200
commit5e271e550dbb88f0bbea5f46aad9f0fd1d750eb3 (patch)
treed0e4c7bb68a6b07019574b5621fb086e8a07557c /src/plugins/test/CMakeLists.txt
parent9946459c0cd65c3b66719a2aefc42c7ab2a29c04 (diff)
downloadcolobot-5e271e550dbb88f0bbea5f46aad9f0fd1d750eb3.tar.gz
colobot-5e271e550dbb88f0bbea5f46aad9f0fd1d750eb3.tar.bz2
colobot-5e271e550dbb88f0bbea5f46aad9f0fd1d750eb3.zip
* New CPluginManager class for managing plugins based on colobot.ini
* Moved sound plugin into sound dir * Minor changes in logger and profile
Diffstat (limited to 'src/plugins/test/CMakeLists.txt')
-rw-r--r--src/plugins/test/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/plugins/test/CMakeLists.txt b/src/plugins/test/CMakeLists.txt
index cd4e6be..5f86b6f 100644
--- a/src/plugins/test/CMakeLists.txt
+++ b/src/plugins/test/CMakeLists.txt
@@ -3,8 +3,10 @@ cmake_minimum_required(VERSION 2.8)
set(CMAKE_BUILD_TYPE debug)
set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11 -rdynamic")
-add_executable(plugin_test plugin_test.cpp ../../common/iman.cpp ../../common/logger.cpp ../pluginloader.cpp)
+add_executable(manager_test manager_test.cpp ../../common/logger.cpp ../../common/profile.cpp ../../common/iman.cpp ../pluginmanager.cpp ../pluginloader.cpp)
+include_directories(".")
include_directories("../../")
+include_directories("../../../")
-target_link_libraries(plugin_test ltdl)
+target_link_libraries(manager_test ltdl)